Skip to:
Content
Pages
Categories
Search
Top
Bottom

Atualizando o BuddyPress

Codex → Atualizações → Atualizando o BuddyPress

Atualizando de uma versão antiga do BuddyPress? Não tem problema, siga as instruções que corresponder à sua situação.

Cópia de segurança – Faça uma cópia de seu banco de dados e todos os arquivos antes de atualizar. Houve grandes mudanças na versão mais antiga do BuddyPress e você vai querer uma cópia de sua configuração existente se a atualização falhar.

Atualizando da versão 1.2.x até 1.5

O BuddyPress 1.5 tem própria documentação sobre a atualização, com informações e conselhos sobre o processo de atualização.Você pode também estar interessado na lista de recursos e correções do BP 1.5.

Atualizando da versão 1.2.5.x para a versão mais recente

A partir da versão 1.2.8, é necessário usar o WordPress 3.1 . Fora isso, não há instruções especiais para atualização de uma versão anterior do BuddyPress 1.2 para a versão mais recente. Por favor, continue com a atualização automática, mas é uma boa ideia  desativar outros plugins além do BuddyPress antes.

Atualizando da versão 1.1.x para 1.2.5

  1. Desative todos os plugins BuddyPress e depois desativar BuddyPress.
  2. Se você não vai usar o novo tema padrão, faça o download, instale e ative o plugin BuddyPress de compatibilidade retroativa
  3. Atualize o BuddyPress automaticamente, ou baixar BuddyPress e substitua os arquivos existentes.
  4. Exclua os arquivos “bp-default” e “bp-sn-parent” da pasta de seu tema.
  5. Se estiver usando o próprio tema personalizado a partir de 1.1, você vai precisar adicionar define( 'BP_CLASSIC_TEMPLATE_STRUCTURE', true ); ao seu arquivo wp-config.php antes da linha “Isso é tudo!”
  6. Ative o BuddyPress. Você não precisará mover nenhum tema desta versão.

Atualizando da versão 1.0.x para 1.2.x

Para atualizar do o BuddyPress 1.0 para 1.2 primeiro você precisa fazer o download da versão 1.1 e atualizar manualmente substituindo a pasta do plugin BuddyPress. Uma vez que você estiver executando o 1.1, por favor siga as instruções para a atualização do 1.1.

É importante notar que, se você ainda está usando a antiga instalação de tema (tema para membros & tema para home), então esse tema não mais vai funcionar na versão 1.2. É preciso mesclar o tema em um só (em inglês). Se estiver rodando um tema WordPress padrão como o tema home, leia o guia rodando o BuddyPress em um subblog (em inglês). Se estiver rodando uma integração com o bbPress, será preciso acessar o Assistente de Conexão em BuddyPress > Fóruns > Usar Instalação Existente, em seu painel WordPress após atualizar para a versão. 12.

Skip to toolbar